<!doctype html>
<html class="" lang="">
<head>
        <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[(new Date).getTime()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=NREUM;"undefined"==typeof window.newrelic&&(newrelic=f);var s=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit"],l="api-",p=l+"ixn-";a(s,function(e,t){f[t]=o(l+t,!0,"api")}),f.addPageAction=o(l+"addPageAction",!0),f.setCurrentRouteName=o(l+"routeName",!0),t.exports=newrelic,f.interaction=function(){return(new r).get()};var d=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(p+"tracer",[Date.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[Date.now(),r,o],n),o)try{return t.apply(this,arguments)}finally{c.emit("fn-end",[Date.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){d[t]=o(p+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,(new Date).getTime()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o){if(!p.aborted){e&&e(n,r,o);for(var i=t(o),a=v(n),u=a.length,c=0;c<u;c++)a[c].apply(i,r);var f=s[w[n]];return f&&f.push([y,n,r,i]),i}}function d(e,t){b[e]=v(e).concat(t)}function v(e){return b[e]||[]}function g(e){return l[e]=l[e]||o(n)}function m(e,t){f(e,function(e,n){t=t||"feature",w[n]=t,t in s||(s[t]=[])})}var b={},w={},y={on:d,emit:n,get:g,listeners:v,context:t,buffer:m,abort:a,aborted:!1};return y}function i(){return new r}function a(){(s.api||s.feature)&&(p.aborted=!0,s=p.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},l={},p=t.exports=o();p.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!h++){var e=y.info=NREUM.info,t=l.getElementsByTagName("script")[0];if(setTimeout(f.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return f.abort();c(b,function(t,n){e[t]||(e[t]=n)}),u("mark",["onload",a()],null,"api");var n=l.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===l.readyState&&i()}function i(){u("mark",["domContent",a()],null,"api")}function a(){return(new Date).getTime()}var u=e("handle"),c=e(2),f=e("ee"),s=window,l=s.document,p="addEventListener",d="attachEvent",v=s.XMLHttpRequest,g=v&&v.prototype;NREUM.o={ST:setTimeout,CT:clearTimeout,XHR:v,REQ:s.Request,EV:s.Event,PR:s.Promise,MO:s.MutationObserver},e(1);var m=""+location,b={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-998.min.js"},w=v&&g&&g[p]&&!/CriOS/.test(navigator.userAgent),y=t.exports={offset:a(),origin:m,features:{},xhrWrappable:w};l[p]?(l[p]("DOMContentLoaded",i,!1),s[p]("load",r,!1)):(l[d]("onreadystatechange",o),s[d]("onload",r)),u("mark",["firstbyte",a()],null,"api");var h=0},{}]},{},["loader"]);</script>
    <meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">

    <title>Missy Elliott Debuts Electric New Song and Video &#039;I&#039;m Better&#039; | Billboard</title>

            <meta name="title" property="title" content="Missy Elliott Debuts Electric New Song and Video &#039;I&#039;m Better&#039;" />
            <meta name="description" property="description" content="The hip-hop legend goes minimal in this slow groove, Autotune-heavy number. It&#039;s clip is out of this world." />
            <meta name="og:title" property="og:title" content="Missy Elliott Debuts Electric New Song and Video &#039;I&#039;m Better&#039;: Watch" />
            <meta name="og:description" property="og:description" content="The hip-hop legend goes minimal in this slow groove, Autotune-heavy number. It&#039;s clip is out of this world. " />
            <meta name="og:image" property="og:image" content="http://www.billboard.com/files/media/missy-elliott-press-photo-2016-billboard-1548.jpg" />
            <meta name="og:image:width" property="og:image:width" content="1548" />
            <meta name="og:image:height" property="og:image:height" content="1024" />
            <meta name="og:image:type" property="og:image:type" content="image/jpeg" />
            <meta name="og:url" property="og:url" content="http://www.billboard.com/articles/news/7669840/missy-elliott-im-better" />
            <meta name="twitter:card" property="twitter:card" content="summary_large_image" />
            <meta name="twitter:creator" property="twitter:creator" content="" />
            <meta name="twitter:creator:id" property="twitter:creator:id" content="" />
            <meta name="twitter:url" property="twitter:url" content="http://www.billboard.com/articles/news/7669840/missy-elliott-im-better" />
            <meta name="twitter:title" property="twitter:title" content="Missy Elliott Debuts Electric New Song and Video &#039;I&#039;m Better&#039;: Watch" />
            <meta name="twitter:description" property="twitter:description" content="The hip-hop legend goes minimal in this slow groove, Autotune-heavy number. It&#039;s clip is out of this world. " />
            <meta name="twitter:image" property="twitter:image" content="http://www.billboard.com/files/media/missy-elliott-press-photo-2016-billboard-1548.jpg" />
    
        <meta name="twitter:site" content="@billboard">

        <meta property="og:site_name" content="Billboard" />
    <meta property="og:type" content="article" />

    <link rel="canonical" href="http://www.billboard.com/articles/news/7669840/missy-elliott-im-better">
    <link rel="amphtml" href="http://www.billboard.com/amp/articles/news/7669840/missy-elliott-im-better" >
    
    <link rel="shortcut icon" href="/static/frontend/2017_01_06_1514/assets/images/favicon.ico" type="image/vnd.microsoft.icon" />
    <link rel="apple-touch-icon" href="/static/frontend/2017_01_06_1514/assets/images/BB_favicon144.png">

    <script type="text/javascript">
    
    var PGM = window.PGM || {};
    PGM.config = PGM.config || {
        contentHost: "http://www.billboard.com",
    };
    (function(PGM) {
        var debug_queue = [];
        PGM.debug = function() {debug_queue.push(arguments);};
        PGM.debug.dump = function() {return debug_queue;}
        PGM.debug.initialCategories = {
                    };
    })(PGM);

    PGM.events = (function() {
        var events_queue = [];
        return {
            trigger: function() {events_queue.push(arguments); },
            get: function() { return events_queue; }
        };
    })();

    PGM.createScript = (function() {
        var q = [], cs = function createScript() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.createScriptTag = (function() {
        var q = [], cs = function createScriptTag() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

        PGM.tests = [];
    PGM.ads = PGM.ads || {};
    PGM.ads.adUnit = '/';
    PGM.ads.slots = PGM.ads.slots || {};
</script>
<script src="http://ads.blbrd.co/advertisement.js"></script>
    <script type="text/javascript">
    
    var PGM = window.PGM || {};
    PGM.mediaQueries = {
        medium: "only screen and (min-width: 768px)",
        large: "only screen and (min-width: 1024px)"
    };
    PGM.ads = PGM.ads || {};
    PGM.ads.allAdsDeferred = true;

</script>

        
<script type='text/javascript'>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</script>

    <script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-1266747-9']);
    _gaq.push(['_setDomainName', 'billboard.com']);
    _gaq.push(['_setAllowLinker', true]);
    _gaq.push(['_trackPageview']);

            _gaq.push(["_setCustomVar", 1, "author", "Billboard Staff"]);

            _gaq.push(["_setCustomVar", 2, "pubDate", "2017012703"]);

    
</script>
    <!-- Google Tag Manager -->
    <script type="text/javascript">
        var dataLayer = dataLayer || [];
        dataLayer.push({
            'fireGTM': 'on'
                        , 'contentId': '7669840'

                    , 'contentType': 'article'

                    , 'author': 'Billboard Staff'

                    , 'category': 'Hip-Hop'

                    , 'tags': 'Missy Elliott, Dave Meyers, Sean Bankhead'

                    , 'publishDate': '2017012703'

            
        });
        dataLayer.push({'gtm.start':new Date().getTime(),event:'gtm.js'});
        PGM.createScript('//www.googletagmanager.com/gtm.js?id=GTM-MD3ZLS');
    </script>
    <!-- End Google Tag Manager -->
    <!-- Begin comScore Tag -->
<script>
    var _comscore = _comscore || [];
    var comscoreVars = {
        c1: "2"
        ,c2: "7395269"
        ,c3: ""
        };
    _comscore.push(comscoreVars);
    </script>
    <script type="text/javascript" data-src="http://b.scorecardresearch.com/beacon.js"></script>
<noscript>
    <img src="http://b.scorecardresearch.com/p?c1=2&c2=7395269&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->
        <script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>

            <link rel="stylesheet" type="text/css" href="/static/frontend/2017_01_06_1514/assets/css/article.css">
    
        
    <script type='text/javascript'>
        var BB = BB || {};
        BB.config = BB.config || {
            contentHost: "http://www.billboard.com",
            mediaHost: "http://www.billboard.com"
        };
    </script>

        <script type="text/javascript">
        window._taboola = window._taboola || [];
        _taboola.push({ article :'auto'});
        PGM.createScript('//cdn.taboola.com/libtrc/prometheus-billboard/loader.js');
    </script>
</head>
<body class="article-page" data-trackcategory="Article" data-twitter-handle="billboard">


<header class="site-header-old jps-siteHeaderOld" role="banner">
    <nav class="nav-secondary">
        <div class="container">
            <ul>
                                    <li>
                        <a  href="/videos">Videos</a>
                                            </li>
                                    <li>
                        <a  href="/photos">Photos</a>
                                            </li>
                                    <li>
                        <a  href="/lists">Lists</a>
                                            </li>
                                    <li>
                        <a  href="/reviews">Live</a>
                                            </li>
                                    <li>
                        <a  href="/artists/top-100">Artists</a>
                                            </li>
                                    <li>
                        <a  href="/podcasts">Podcasts</a>
                                            </li>
                                    <li>
                        <a  href="/pop">Pop</a>
                                            </li>
                                    <li>
                        <a  href="/hip-hop-rap-r-and-b">R&amp;B/Hip-Hop</a>
                                            </li>
                                    <li>
                        <a  href="/chart-beat">Chart Beat</a>
                                            </li>
                                    <li>
                        <a  href="/node/6805681">Super Bowl LI</a>
                                            </li>
                            </ul>
        </div>
    </nav>
    <div class="container top-content">
        <h1 class="billboard brand" title="Billboard"><a href="/">Billboard</a></h1>

        <div class="header-social-content">
            <div class="subscription-wrap">
                <a href="https://subscribe.billboard.com/sub/?p=BBL&amp;f=sale&amp;s=IB1404NS04">Subscribe</a>
                <a href="/newsletters">Newsletters</a>
            </div>
            <div class="subscribe-feature-image">
                <a href="https://subscribe.billboard.com/sub/?p=BBL&amp;f=sale&amp;s=IB1404NS04">
                    <img src="http://www.billboard.com/files/styles/top_cover/public/media/bb2-pandora-kdo-2017-billboard-225.jpg" alt="Subscribe to Billboard"/>
                </a>
            </div>

            <nav class="nav-social">
                <ul class="follow-us">

                    <li>
                        <a href="http://www.facebook.com/Billboard"><i class="fa fa-facebook">Facebook</i></a>
                    </li>
                    <li>
                        <a class="fa fa-twitter" href="http://twitter.com/billboard">Twitter</a>
                    </li>
                    <li>
                        <a class="fa fa-google" href="https://plus.google.com/+Billboard">Google Plus</a>
                    </li>
                    <li>
                        <a class="fa fa-pinterest" href="https://www.pinterest.com/billboard/">Pinterest</a>
                    </li>
                    <li>
                        <a class="fa fa-instagram" href="http://instagram.com/billboard">Instagram</a>
                    </li>
                    <li>
                        <a class="fa fa-tumblr" href="http://billboard.tumblr.com/">Tumblr</a>
                    </li>
                </ul>
            </nav>
        </div>
    </div>

    <div class="container">
        <nav class="nav-primary">
            <button class="nav-toggle"><i class="fa fa-bars fa-lg"></i></button>
            <ul class="nav-items">
                                    <li>
                        <a  href="/sundance-music" >
                            Sundance 2017                        </a>
                                            </li>
                                    <li class="dropdown">
                        <a  href="/news" >
                            News                        </a>
                                                    <ul>
                                                                    <li>
                                        <a  href="/festivals">
                                            Music Festivals
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/pop">
                                            Pop
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/hip-hop-rap-r-and-b">
                                            R&amp;B/Hip-Hop
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/style">
                                            Style
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/country">
                                            Country
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/dance">
                                            Dance
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/latin">
                                            Latin
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/rock">
                                            Rock
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/k-pop">
                                            K-Pop
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/biz">
                                            Business
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="http://www.pretareporter.com">
                                            Pret-a-Reporter
                                        </a>
                                    </li>
                                                            </ul>
                                            </li>
                                    <li>
                        <a  href="/charts/hot-100" >
                            Hot 100                        </a>
                                            </li>
                                    <li>
                        <a  href="/charts/billboard-200" >
                            Billboard 200                        </a>
                                            </li>
                                    <li class="dropdown">
                        <a  href="/charts" >
                            Charts                        </a>
                                                    <ul>
                                                                    <li>
                                        <a  href="http://www.billboard.com/charts/year-end">
                                            Year-End 2016
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-greatest-of-all-time">
                                            Greatest of All Time
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts/artist-100">
                                            Artist 100
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="http://www.billboard.com/charts#id-chart-category-web">
                                            Spotify + Web
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="http://realtime.billboard.com/?chart=trending140">
                                            Trending 140
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="http://realtime.billboard.com/?chart=emergingartists">
                                            Emerging Artists
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-rbhip-hop">
                                            R&amp;B/Hip-Hop
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-pop">
                                            Pop
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-danceelectronic">
                                            Dance/Electronic
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-country">
                                            Country
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-rock">
                                            Rock
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-latin">
                                            Latin
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-breaking-and-entering">
                                            Breaking and Entering
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-christiangospel">
                                            Christian/Gospel
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-holiday">
                                            Holiday
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="http://www.billboard.com/charts/att-sports/">
                                            Sports
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-international">
                                            International
                                        </a>
                                    </li>
                                                                    <li>
                                        <a  href="/charts#id-chart-category-additional-genres">
                                            Additional Genres
                                        </a>
                                    </li>
                                                            </ul>
                                            </li>
                                    <li>
                        <a  href="/videos" >
                            Videos                        </a>
                                            </li>
                            </ul>
        </nav>

        <div class="search-wrap">
            <button class="close-search search-toggle  d"><i class="fa fa-times"></i></button>
            <form accept-charset="UTF-8" action="/" id="site-search-form" class="site-search-form" method="post">
                <label for="search_block_form">Search</label>

                <input class="search-text-input" maxlength="128" name="search_block_form" placeholder="Search Billboard" size="0" type="text" value="">
                <button class="form-submit" name="op" type="submit">
                    <i class="fa fa-search"></i>
                </button>
                <input name="form_id" type="hidden" value="search_block_form">
            </form>
        </div>
        <button class="open-search search-toggle"><i class="fa fa-search"></i></button>
    </div>
</header>

<div class="leaderboard leaderboard--top">
        <div class="dfp-ad dfp-ad-t  is-dfp-deferred " data-trackaction="Top Banner Ad" data-tracklabel="Ad Click">
        <script type="application/json">
            { "slot": {"adUnit":"\/6419\/billboard\/articles\/news","slotName":"t","outOfBody":false,"responsive":true,"sizeMapping":{"1024":[[990,350],[970,250],[970,90],[970,66],[728,91],[980,50],[980,250],[970,415]],"768":[[728,91]],"0":[[300,50],[320,50],[320,170],[300,51],[320,51]]},"targetingParameters":{"pos":["t"]}}, "extraTargeting": null }
        </script>
    </div>
                <div id="dfp-ad-o1" class="dfp-ad dfp-ad-o1"></div>
        </div>

<main id="main" class="page-content">
                
        <main class="article">
    <section class="left-rail js-leftRail-container">
        <div class="left-rail__list js-leftRail"></div>
<script type="application/json">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</script>
    </section>
    <section class="main-well js-mainWell">
        <article class="article__content-well article__content-well--landscape js-revarticle url-breadcrumb is-active " data-id="7669840" data-url-breadcrumb="/articles/news/7669840/missy-elliott-im-better" data-content-type="article" data-page-title="Missy&#x20;Elliott&#x20;Debuts&#x20;Electric&#x20;New&#x20;Song&#x20;and&#x20;Video&#x20;&#x27;I&#x27;m&#x20;Better&#x27;" data-canonical="http://www.billboard.com/articles/news/7669840/missy-elliott-im-better" data-chartbeatSection="" data-analytics-category="Hip-Hop" data-analytics-tags="Missy Elliott, Dave Meyers, Sean Bankhead">

        <div class="article__header">
    <h1 class="article__headline">Missy Elliott Debuts Electric New Song and Video &#039;I&#039;m Better&#039;: Watch</h1>
            <p class="article__meta">
    <span class="js-publish-date"  data-pubdate-value="2017012703">
        1/27/2017
    </span>
            by
        <span class="js-authors-list">
                    <span class="author">
                                    <a href="/author/6051" class="article__author-link">Billboard Staff</a>
                            </span>            </span>
</p>
        <ul class="social-share">
    <li class="social-share__item">

        <a class="js-pgm-social-share social-share__link social-share__link--facebook fa-facebook" data-pgm-share="facebook" data-pgm-title="Missy&#x20;Elliott&#x20;Debuts&#x20;Electric&#x20;New&#x20;Song&#x20;and&#x20;Video&#x20;&#x27;I&#x27;m&#x20;Better&#x27;&#x3A;&#x20;Watch" data-pgm-url="http&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;news&#x2F;7669840&#x2F;missy-elliott-im-better" href="javascript:void(0);">
            FACEBOOK
        </a>
    </li>
    <li class="social-share__item">
        <a class="js-pgm-social-share social-share__link social-share__link--twitter fa-twitter" data-pgm-share="twitter" data-pgm-title="Missy&#x20;Elliott&#x20;Debuts&#x20;Electric&#x20;New&#x20;Song&#x20;and&#x20;Video&#x20;&#x27;I&#x27;m&#x20;Better&#x27;&#x3A;&#x20;Watch" data-pgm-url="http&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;news&#x2F;7669840&#x2F;missy-elliott-im-better" href="javascript:void(0);">
            TWITTER
        </a>
    </li>
    <li class="social-share__item">
        <a class="social-share__link social-share__link--email fa-envelope" data-pgm-title="Missy&#x20;Elliott&#x20;Debuts&#x20;Electric&#x20;New&#x20;Song&#x20;and&#x20;Video&#x20;&#x27;I&#x27;m&#x20;Better&#x27;&#x3A;&#x20;Watch" href="mailto:?body=http&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;news&#x2F;7669840&#x2F;missy-elliott-im-better&subject=Missy&#x20;Elliott&#x20;Debuts&#x20;Electric&#x20;New&#x20;Song&#x20;and&#x20;Video&#x20;&#x27;I&#x27;m&#x20;Better&#x27;&#x3A;&#x20;Watch">
            EMAIL ME
        </a>
    </li>
        <li class="social-share__item">
        <a class="social-share__link social-share__link--print fa-print" target="_blank" href="/print/7669840">
            PRINT
        </a>
    </li>
            <li class="social-share__item">
            <a class="social-share__link social-share__link--comments js-scroll-to-comments fa-comment" href="javascript:void(0);">
                COMMENTS
            </a>
        </li>
    </ul>
    </div>
            <figure class="main-media main-media--image " data-media-type="image" data-media-id="">
                                                    <div class="ndn_embed" data-config-distributor-id="91574" data-config-height="9/16w" id="ndn-video-player-1" style="width:100%;">
                            <img src="http://www.billboard.com/files/styles/article_main_image/public/media/missy-elliott-press-photo-2016-billboard-1548.jpg" class="main-media__image">

                                    <figcaption class="media__details-text">
                                            <div class="media__credit">Derek Blanks</div>
                                                                <div class="media__caption">Missy Elliott</div>
                                        </figcaption>
                                            </div>
                        </figure>
            <div class="article__body js-fitvids-content">
        <div class="dfp-ad dfp-ad-m2  is-dfp-deferred " data-trackaction="" data-tracklabel="Ad Click">
        <script type="application/json">
            { "slot": {"adUnit":"\/6419\/billboard\/articles\/news","slotName":"m2","outOfBody":false,"responsive":true,"sizeMapping":{"1024":[[300,250],[300,252]],"768":[[300,250],[300,252]],"0":[[300,50],[320,50],[300,250]]},"targetingParameters":{"pos":["m2"],"dartlegolas":["segments"],"amazon":["1"]}}, "extraTargeting": null }
        </script>
    </div>
        <p><a href="/artist/311508/missy-elliott/chart"><strong>Missy Elliott</strong></a>, <strong>Lamb</strong> and a cadre of space cadets get their freak on for the new video, &ldquo;I&rsquo;m Better&rdquo;.</p><p>The hip-hop legend goes minimal in this slow groove, Autotune-heavy number which dropped overnight with a stylized, can&rsquo;t-look-away clip.</p><p>Directed by Dave Meyers and Elliott, the video is loaded with lasers, floodlights, angles and wild choreography (arranged by Sean Bankhead and Elliott).&nbsp;</p><p>
    <div class="embedded-content" data-nid="7431180" data-nodetype="article" data-template="readmore">
      <script type="application/json">
          {"path":"http:\/\/www.billboard.com\/articles\/columns\/hip-hop\/7431180\/missy-elliott-interview","title":"Missy Elliott: People Don&#039;t Know All the Songs I&#039;ve Produced","type":"article","id":"7431180","relative_path":"\/articles\/columns\/hip-hop\/7431180\/missy-elliott-interview","image":{"source":"Getty","title":null,"title_text":null,"path_original":"\/files\/media\/missy-elliott-2016-sxsw-billboard-1548-2.jpg","path":"\/files\/media\/missy-elliott-2016-sxsw-billboard-1548-2.jpg","image_path_original":"\/files\/media\/missy-elliott-2016-sxsw-billboard-1548-2.jpg","file_uri":"public:\/\/media\/missy-elliott-2016-sxsw-billboard-1548-2.jpg","extension":"jpg","type":"image","mime_type":"image\/jpeg","file_size":1214803,"width":1548,"height":1024,"orientation":"landscape","caption":"Missy Elliott speaks on stage during the SXSW Keynote: Michelle Obama during 2016 SXSW Music, Film + Interactive Festival at Austin Convention Center on March 16, 2016 in Austin, Texas.\u00a0","credit":"Neilson Barnard\/Getty Images for SXSW","animated":false}}
      </script>
    </div></p><p>&ldquo;Yeah he got bands in the Bando/Missy got dudes in Orlando/Plus I got cars that he paying for/Man I be too much to handle,&rdquo; she raps.</p><p>The four cloaked and tethered dancers are totally worth your attention and the aquatic sequence is an unexpected trip.&nbsp;</p><p>Elliott&rsquo;s last album proper was 2005&rsquo;s <em>The Cookbook</em>, which reached No. 2 on the Billboard 200.&nbsp;Watch the new clip below.<br /><br /><iframe allowfullscreen="" frameborder="0" height="315" src="https://www.youtube.com/embed/TwyPsUd9LAk" width="560"></iframe></p>
</div>
                        <div class="dfp-ad dfp-ad-t2  is-dfp-deferred " data-trackaction="" data-tracklabel="Ad Click">
        <script type="application/json">
            { "slot": {"adUnit":"\/6419\/billboard\/articles\/news","slotName":"t2","outOfBody":false,"responsive":true,"sizeMapping":{"1024":[[644,380]],"768":[[728,90],[644,380]],"0":[[300,50],[320,50],[300,300]]},"targetingParameters":{"pos":["t2"]}}, "extraTargeting": null }
        </script>
    </div>
                <div class="article-meta-bottom">
            <ul class="social-share social-share--bottom">
    <li class="social-share__item">

        <a class="js-pgm-social-share social-share__link social-share__link--facebook fa-facebook" data-pgm-share="facebook" data-pgm-title="Missy&#x20;Elliott&#x20;Debuts&#x20;Electric&#x20;New&#x20;Song&#x20;and&#x20;Video&#x20;&#x27;I&#x27;m&#x20;Better&#x27;&#x3A;&#x20;Watch" data-pgm-url="http&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;news&#x2F;7669840&#x2F;missy-elliott-im-better" href="javascript:void(0);">
            FACEBOOK
        </a>
    </li>
    <li class="social-share__item">
        <a class="js-pgm-social-share social-share__link social-share__link--twitter fa-twitter" data-pgm-share="twitter" data-pgm-title="Missy&#x20;Elliott&#x20;Debuts&#x20;Electric&#x20;New&#x20;Song&#x20;and&#x20;Video&#x20;&#x27;I&#x27;m&#x20;Better&#x27;&#x3A;&#x20;Watch" data-pgm-url="http&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;news&#x2F;7669840&#x2F;missy-elliott-im-better" href="javascript:void(0);">
            TWITTER
        </a>
    </li>
    <li class="social-share__item">
        <a class="social-share__link social-share__link--email fa-envelope" data-pgm-title="Missy&#x20;Elliott&#x20;Debuts&#x20;Electric&#x20;New&#x20;Song&#x20;and&#x20;Video&#x20;&#x27;I&#x27;m&#x20;Better&#x27;&#x3A;&#x20;Watch" href="mailto:?body=http&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;news&#x2F;7669840&#x2F;missy-elliott-im-better&subject=Missy&#x20;Elliott&#x20;Debuts&#x20;Electric&#x20;New&#x20;Song&#x20;and&#x20;Video&#x20;&#x27;I&#x27;m&#x20;Better&#x27;&#x3A;&#x20;Watch">
            EMAIL ME
        </a>
    </li>
        <li class="social-share__item">
        <a class="social-share__link social-share__link--print fa-print" target="_blank" href="/print/7669840">
            PRINT
        </a>
    </li>
            <li class="social-share__item">
            <a class="social-share__link social-share__link--comments js-scroll-to-comments fa-comment" href="javascript:void(0);">
                COMMENTS
            </a>
        </li>
    </ul>
                    </div>
            <div class="taboola-wrapper"></div>
            <div class="zergnet-widget"></div>
                    <script language="javascript" type="text/javascript">
        PGM.createScript('//www.zergnet.com/zerg-inf.js?id=36521');
    </script>
        <button class="js-toggle-disqus-comments disqus-comments-toggle">Comments</button>
<div id="disqus_thread" class="disqus-comments"></div>
<script type="text/javascript">
    var disqus_shortname = 'billboardcom';
    PGM.createScript('//billboardcom.disqus.com/embed.js');
</script>
            <div class="js-leftRail-slot-m1" data-trackaction="" data-tracklabel="Ad Click">
        <script type="application/json">
            {"adUnit":"\/6419\/billboard\/articles\/news","slotName":"m1","outOfBody":false,"responsive":true,"sizeMapping":{"1024":[[300,250],[300,600],[300,251]],"768":[[300,250],[300,600],[300,251]],"0":[[300,50],[320,50],[300,250],[300,51],[320,51]]},"targetingParameters":{"pos":["m1"],"amazon":["1"]}}
        </script>
    </div>
    <div class="js-ad-pageTargeting">
        <script type="application/json">
        {
                            "tags_global": ["fe-api","articles","news","7669840","missy-elliott-im-better","[node:chart_primary_category]"],
                            "page": ["7669840"],
                            "tags": ["Hip-Hop","news","hip-hop"],
                            "env": ["prod"]
                    }
        </script>
    </div>
</article>

<div class="js-leftRail-loadNewContent" data-currentId="7669840" data-urlPrefix="/fe_data" ></div>

    </section>
</main>
</main>

<footer id="site-footer" class="site-footer">
	<div class="container footer-content">
		<div class="cover-image">
			<a href="https://subscribe.billboard.com/sub/?p=BBL&amp;f=sale&amp;s=IB1404NS04">
				<img src="http://www.billboard.com/files/styles/magazine_cover/public/media/bb2-pandora-kdo-2017-billboard-225.jpg" alt="Subscribe to Billboard">
			</a>
		</div>
		<div class="subscribe">
			<h2>Magazine</h2>
			<ul>
				<li><a class="site-footer__link" href="https://subscribe.billboard.com/sub/?p=BBL&f=landing" title="Customer Service">Customer Service</a></li>
				<li><a class="site-footer__link" href="https://subscribe.billboard.com/sub/?p=BBL&f=sale&s=IB1404NS03" title="Subscribe">Subscribe</a></li>
				<li><a class="site-footer__link" href="http://shop.billboard.com/" title="Buy this issue">Buy this issue</a></li>
			</ul>
			<h2>Billboard biz</h2>
			<p>The online extension of Billboard Magazine, billboard.biz is the essential online destination for the music business.</p>
			<p><a class="site-footer__link" href="/biz" title="Learn More">Learn More</a></p>
		</div>
		<nav class="footer-nav">
			<h2>Sharing Billboard</h2>
			<ul>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;www.facebook.com&#x2F;Billboard">Facebook</a></li>
				<li><a class="site-footer__link"  href="https&#x3A;&#x2F;&#x2F;twitter.com&#x2F;billboard">Twitter</a></li>
				<li><a class="site-footer__link"  href="https&#x3A;&#x2F;&#x2F;plus.google.com&#x2F;&#x2B;Billboard&#x2F;posts">Google+</a></li>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;youtube.com&#x2F;billboard">YouTube</a></li>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;instagram.com&#x2F;billboard">Instagram</a></li>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;billboard.tumblr.com&#x2F;">Tumblr</a></li>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;pinterest.com&#x2F;billboard">Pinterest</a></li>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;open.spotify.com&#x2F;app&#x2F;billboard">Spotify</a></li>
				<li><a class="site-footer__link"  href="&#x2F;newsletters">Newsletter</a></li>
			</ul>
		</nav>
		<nav class="footer-nav">
			<h2>Explore Billboard</h2>
			<ul>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;shop">Shop</a></li>
				<li><a class="site-footer__link"  href="&#x2F;archive&#x2F;article">News Archive</a></li>
				<li><a class="site-footer__link"  href="&#x2F;photos">Photos Archive</a></li>
				<li><a class="site-footer__link"  href="&#x2F;archive&#x2F;video_item">Videos Archive</a></li>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;magazine-archive">Magazine Archive</a></li>
				<li><a class="site-footer__link"  href="&#x2F;archive&#x2F;charts">Charts Archive</a></li>
			</ul>
		</nav>
		<nav class="footer-nav">
			<h2>Information</h2>
			<ul>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;prometheusglobalmedia.applytojob.com&#x2F;">Jobs</a></li>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;billboardlicensing.licensestream.com">Chart Licensing</a></li>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;www.billboardevents.com&#x2F;">Billboard Events</a></li>
				<li><a class="site-footer__link"  href="&#x2F;articles&#x2F;news&#x2F;468196&#x2F;contact-us">Contact Us</a></li>
				<li><a class="site-footer__link"  href="&#x2F;sitemap">Sitemap</a></li>
				<li><a class="site-footer__link"  href="&#x2F;faq">FAQ</a></li>
				<li><a class="site-footer__link"  href="https&#x3A;&#x2F;&#x2F;docs.google.com&#x2F;spreadsheet&#x2F;viewform&#x3F;formkey&#x3D;dDZ1RmJPWndBRmc0cThUOEMwMXhLMXc6MQ&#x23;gid&#x3D;0">Feedback</a></li>
				<li><a class="site-footer__link"  href="http&#x3A;&#x2F;&#x2F;www.metrolyrics.com&#x2F;">Lyrics</a></li>
			</ul>
		</nav>
		<div class="footer-brand">
			<div class="billboard brand">
                <a class="site-footer__link" href="/">Billboard</a>
            </div>
			<div class="affiliates">
                <a href="http://www.backstage.com/" title="Backstage Casting" target="_blank" class="site-footer__link backstage">Backstage</a>
                <a href="http://www.sonicbids.com/" title="Sonicbids Gigs" target="_blank" class="site-footer__link sonicbids">Sonicbids</a>
            </div>
		</div>
	</div>
	<div class="container">
		<p class="copyright__paragraph">&copy; 2017 Billboard. All Rights Reserved.</p>
		<p class="copyright__paragraph">
			<a class="copyright__link" href="/terms-of-use">Terms of Use</a>
            <a class="copyright__link" href="/privacy-policy">Privacy Policy</a>
            <a class="copyright__link" href="/about-our-ads">About Our Ads</a>
			<a class="copyright__link copyright__link--contrast" href="http://www.billboard.com/advertising">Advertising</a>
		</p>
	</div>
	<div class="container">
		<p class="station-identification">
			Billboard.com is a member of Billboard Music, a division of Billboard-Hollywood Reporter Media Group
		</p>
	</div>
</footer>


    <script type="text/javascript" src="/static/frontend/2017_01_06_1514/assets/js/commons.bundle.js"></script>
    <script type="text/javascript" src="/static/frontend/2017_01_06_1514/assets/js/transition.bundle.js"></script>
    <script type="text/javascript" src="/static/frontend/2017_01_06_1514/assets/js/templates.js"></script>
    <script type="text/javascript" src="/static/frontend/2017_01_06_1514/assets/js/home.bundle.js"></script>
    <script type="text/javascript" src="/static/frontend/2017_01_06_1514/assets/js/vendor.js"></script>
    <script type="text/javascript" src="/static/frontend/2017_01_06_1514/assets/js/bb.js"></script>


<!-- PGM Chartbeat Start -->
<script type='text/javascript'>
	var _sf_async_config={};
	/** CONFIGURATION START **/
	_sf_async_config.uid = 3388;
	_sf_async_config.domain = 'billboard.com';
	_sf_async_config.useCanonical = true;
	/** CONFIGURATION END **/
	PGM.createScript('//static.chartbeat.com/js/chartbeat.js');
</script>
<!-- PGM Chartbeat End -->
<!-- BEGIN Krux -->
<script class="kxct" data-id="JsVUOKRj" data-timing="async" data-version="1.9" type="text/javascript">
    window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
    PGM.createScript("//cdn.krxd.net/controltag?confid=JsVUOKRj");
</script>
<!-- END Krux -->
<script data-src="//platform.instagram.com/en_US/embeds.js"></script>
<script data-src="//platform.twitter.com/widgets.js"></script>
<div id="fb-root"></div>
<script type="text/javascript">
    PGM.createScriptTag("//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=303838389949803");
</script>
    <script type="text/javascript">
        PGM.createScript('//launch.newsinc.com/js/embed.js', function() {
            if( _informq && typeof _informq.push === 'function' ) {
                _informq.push(['embed']);
            }
        });
    </script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"645958bbf2","applicationID":"3969137","transactionName":"YAZRbEJXC0VUURFZV1lMZkpZGQxYUVcdHkhfEw==","queueTime":0,"applicationTime":894,"atts":"TEFSGgpNGEs=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
